Negatiivin oranssin maskin poisto digikuvasta
Törmäsin keskusteluun, jossa jaettiin Mr. Burtonin Adobe Forumissa julkaisema teksti aiheesta.
Maskivärin poisto saatu: http://www.dpreview.com/forums/post/499854
Ohessa mun lyhyt suomennos periaatteesta:
Negatiivin oranssi maski ei ole vakio yli koko kuva-alueen. Se muodostuu negatiivin kehityksen
aikana käänteisessä suhteessa värin määrään syaani ja magenta tasoilla.
- Keltaisen värin tasolla ei muodostu oranssia maskia ollenkaan
- Syaani värin tasolla punaista maskiväriä muodostuu noin 40% alueilla, joissa ei ole syaania ja
väheten nollaan niillä alueilla, joilla on suurin syaanin määrä.
- Magentan tasolla on noin 20% keltainen maski.
Jos maskinvärin poistaa, niin kuin se olisi joka osassa kuva-alaa vakio, huonontuu värin alueella,
joissa maskia ei ole muodostunut.
Mr. Burtonin teksti:
HOW TO REMOVE THE ORANGE MASK ON NEGATIVE SCANS
By Burton, posted in the Adobe Forum
URL: http://www.adobeforums.com/cgi-bin/webx.fcgi?14@50.AAUnaZDHiKg ^18@.ee9a5c9/0
This is an update on the technique for removing the orange mask from a color negative. Several
months ago in a message here in this forum, Len Hewitt provided the following description of the
orange mask:
The [orange] mask is not constant across the whole negative. It is formed, during development, in
inverse proportion to the amount of dye formed in the Cyan and Magenta layers. No mask is created
in the yellow dye layer. In the cyan dye layer, a red mask is created at about 40% in the areas of no
Cyan dye, down to zero where the cyan reaches D-Max. In the Magenta dye layer it is about a 20%
yellow mask. Removing the cast as though it were constant over the whole area degrades the
colours where the mask wasn't originally formed.
The following Photoshop procedure removes the 20% yellow 40% red mask from a color negative
image. It is not actually as lengthy as this description might seem. After you have obtained a bit of
experience with it, it goes fairly rapidly. Make sure the Layers dialog and the Channels dialog are
separately visible, because this method needs both.
(1) Open a color negative scan as an 8-bit RGB image. Convert it to CMYK with no K, in order to
have the same structure as the color negative film. In order to suppress the K, File > Color Settings
> CMYK Setup... to open the CMYK Setup dialog. For CMYK Model select Built-in, for Ink
Colors select SWOP (Coated), for Dot Gain select Standard and enter -10%, for Separation Type
select UCR and enter a Black Ink Limit of 0% and a Total Ink Limit of 400%. Convert the Parent
image to CMYK and it will lighten noticeably, but it will contain no black ink (the K channel is
white.)
(2) We will create an image containing the 20% yellow mask of the Magenta film layer. On the
Toolbar, make the Foreground Color white and the Background Color black. In order to make this
image exactly the same size as the Parent image, on the Parent image Select All, Edit Copy, and File

New. On the New dialog, name the new image "Yellow Mask", set the Mode to Grayscale, and the
Contents to Background (Black). Click on the Magenta channel of the Parent image and Edit >
Copy it. Click on the titlebar of the Yellow Mask image and Edit > Paste. A Layer 1 appears
containing only a single Grayscale channel. This channel ranges from white to black and we want it
range from 80% white (20% yellow dye strength) down to zero percent yellow dye (Grayscale
black in the Magenta channel.) Merely set the Layer 1 Opacity to 20% and Flatten. The Black
Background reduces the whitest value down to 20%. There is no need to save the Yellow Mask
image -- just keep it open for use in later steps.
(3) Create another image containing the 40% red mask of the Cyan film layer. File, New and name
the image "Red Mask", make sure the Mode is Grayscale and the Contents are Background (Black).
Make the Parent image active again, Select All, click on the Cyan channel, Edit Copy, and click on
the Red Mask image title bar, and Edit Paste. Layer 1 will appear. Change its Opacity to 40% and
Flatten. Also no need to save Red Mask -- just keep it open for use in the following steps.
(4) We are now ready to remove the orange mask components from the Parent image. The Red
Mask image will be removed as superimposed magenta and yellow layers, so it will be used twice.
The Yellow Mask can be removed in a single step. Let's remove it first. On the Parent image, click
on the Yellow channel. We can Deselect the selection now, because we don't need it in the
following. Image > Calculations to open the Calculations dialog. Both Source 1 and Source 2 are
currently defaulted to the Yellow channel of the Background layer of the Parent image. We are
going to use the "Subtract" Blending mode of the Calculations dialog to remove the yellow mask,
and the convention is to subtract Source 1 from Source 2, so we will leave Source 2 filled out just as
it is and change Source 1 to Yellow Mask, Layer Background, Channel Black. Change the Blending
field to Subtract. Since we are dealing with subtractive color we have to carry out our positive
integer arithmetic in the inverted domain. Check the Invert box for Source 2, but do not check the
Invert box on Source 1 because it is already inverted. It is all right to have Preview checked
although sometimes you may be vexed by the preview because we are still working with inverted
components of a color negative image. Opacity should be 100%, Offset 0, Scale 1 (the defaults).
Mask should be unchecked and the Result should be "New Channel." OK to place the Subtract
Calculation in a new channel.
(5) The new channel may be named "Alpha 1." Double-click it (in the Channel dialog) to open the
Channel Options dialog and in the "Color Indicates:" area click on "Spot Color." The new channel
name now defaults to "Spot Color 1". We are still in "inverse space", so Image > Adjust > Invert to
return to the normal "black=dye" subtractive color space. The Spot Color 1 channel now represents
a revised version of the yellow channel, from which we have removed the yellow mask of the
Magenta film layer. You can click on the Yellow channel and then the Spot Color 1 channel and as
you alternate between them you can see that the Spot Color 1 channel contains less yellow (which is
depicted as black in this Grayscale representation) than the Yellow channel. The difference may be
subtle. We could copy the Spot Color 1 channel to the Yellow channel at this point, but for
comparison lets leave it in place for the present, while keeping in mind that it is now our "real"
Yellow channel.
(6) Next, continuing to work in the Channels dialog, lets remove the yellow component of our Red
Mask from the Spot Color 1 channel (our "real" yellow channel.) Click on the Spot Color 1 channel
to make it active and open the Calculations dialog from the Image menu. As before, our selected
channel appears as both Source 1 and Source 2 but we want to use the Red Mask image as Source 1.
Once again, we don't need to invert our Source 1 (Red Mask), but we do need to check Invert for
Source 2. Blending is still Subtract, Opacity 100%, Offset 0, Scale 1, Mask blank, and Result "New
Channel." OK to put the result of the subtraction in a new channel, which will probably have the
name "Spot Color 2" (Photoshop may have temporarily "learned" that we don't want Alpha

channels.) The new "Spot Color 2" channel now represents our new unmasked Yellow channel and
it is still Inverted, so Invert it to return it to the subtractive black dye mode (Image > Adjust > Invert
(or Ctrl+i) with only the Spot Color 2 channel highlighted.) You can now compare the original
Yellow channel with Spot Color 1 and Spot Color 2 to see the effects of "peeling off" two layers of
yellow mask. Pure black still represents pure yellow in the Grayscale representation of the yellow
channel, so Spot Color 2 should be less black than Spot Color 1 which should be less black than the
Yellow channel. We can now replace the contents of the Yellow channel with the Spot Color 2
contents. Click on the Spot Color 2 channel, Select All (Ctrl+a) and Edit Copy (Ctrl+c) to put it on
the ClipBoard. Click on the Yellow channel and Paste in (Ctrl+v) the new contents. We have no
further use for the Spot Color 1 and Spot Color 2 channels, so we can simply drag them to the
Trashcan icon at the bottom of the Channels dialog box.
(7) We now want to strip the magenta layer of the Red Mask from the Magenta channel of the
Parent image. On the Channels dialog, click on the Magenta channel so that it is the only
highlighted channel of the Parent image. Open the Calculations dialog and change Source 1 to the
Red Mask image. As before, Source 1 does not need Invert checked, but Source 2 does. OK to
create a new channel containing the result of the subtraction. The new channel is probably named
"Alpha 1" (Photoshop forgets) so double-click it to open the Channel Options dialog box and check
Spot Color. (Don't worry that the Spot Color color square appears as yellow -- we are just going to
use the Grayscale information.) The name of the channel changes to Spot Color 1. While it is still
the only active channel, Invert it.
(8) The Spot Color 1 channel now represents our revised Magenta channel which has had the red
mask of the filmbase's Cyan layer removed from it. Compare Spot Color 1 with the Magenta
channel to see that Spot Color 1 has less magenta dye (black) than the original Magenta channel.
We ill now copy the contents of the Spot Color 1 channel to the Magenta channel. If Select All is
still not in effect, do a Select All and click on the Spot Color 1 channel to select it and Copy it.
Click on the Magenta channel and Paste. The Magenta channel has now had its part of the orange
mask removed. We no longer need the Spot Color 1 channel, so we can drag it to the Channels
TrashCan.
(9) This completes the removal of the filmbase orange mask from the color negative image. We are
now nearly ready to invert the Parent image color negative to a color positive. But first, remember
that we converted the color negative from an RGB to a CMYK image with no black channel,
because the color negative film itself does not have a black channel. The current Black channel is
filled with pure white, indicating no black dye at all, and if we were to invert this CMYK image the
Black channel would go from pure white to pure black, making the entire image solid black. To
avoid this problem, and because we will be making extensive image adjustments after the
conversion to a color positive, it is appropriate to convert the image mode from CMYK to RGB at
this point. We can also Deselect because we no longer need the selection in effect. The conversion
to RGB should cause no visible appearance change.
(10) Now, in this next step, don't panic. Convert the image from a color negative to a color positive
with an Image > Adjust > Invert. The result will not look like a good final result for several reasons
(the reason for the "no panic" warning.) First and foremost, the color negative film representation
has a very limited dynamic range (no deep blacks or pure whites) and the color print process
compensates for this by automated (and sometimes manual) adjustments in the color printing
equpment. Therefore it is perfectly normal to need to make large adjustments in Photoshop in order
to put this color positive image in an acceptable final form. Another factor contributing to needed
correction is that the actual filmbase orange mask may differ significantly from the 20%-yellow,
40%-red mask that we removed. (An improved version of this method will account for this by using
and analyzing a measured sample of the filmbase mask.) A third factor is that the scanned image

may contain image elements (sprocket holes, film border, etc.) that are not actually part of the
image but contribute spurious components to the image histogram. To remedy this last problem,
crop the image to include only relevant material. Since the following series of Photoshop image
adjustments will be extensive, convert to the 16-bit RGB mode to help avoid fragmentation of the
image's histogram. It may be advisable to upsample the 16-bit image to get a significantly higher
pixel count (and filesize) before the image adjustment phase.
(11) The quickest way to significantly improve the image is to use Image > Adjust > Levels. Don't
use Auto Levels -- the image needs your personal attention. You can use whatever image adjustment
techniques you like from this point on. I like to adjust the R, G, and B channels individually
because they usually have significantly different histograms. Select the R channel and move the
Black point to the right to enter the histogram slightly. Move the White point to the left enough to
enter the edge of the Red histogram. Repeat for the Green and Blue histograms. Then start
experimenting with the Mid-Gray (gamma) points. For more precise control, you can highlight the
entry field and "nudge" the values with the Up-arrow and Down-arrow keys. Once the Levels
adjustments have been made, the image should have a much wider dynamic range, ranging from
near-black darks to near-white lights. You are then free to use whatever additional image
adjustments you deem necessary. After making all of the image adjustments, change the Image
Mode to 8-bit RGB for any needed filters work. A tiny bit of Gaussian blur can fill in some of the
gaps in the histograms. Downsample if the pixel count is inappropriately high.
This method was developed using Photoshop 5.0.2, but should work with Photoshop 4.0.1 and
higher. This method rigorously removes the 20%-yellow 40%-red masks, but it is not the final
answer because real world masks vary significantly from those specifications. I am developing an
improved method to accommodate varying mask characteristics.
Burton -P.S. I would like to express my sincere appreciation to both Peter Hunter and Patrice Boone, who
supplied me with a variety of scanned color negative images, which were a big help in developing
this method, and which will be instrumental in developing the aforementioned enhancement.

